Epicor2@ Planned Maintenance

Scheduled for Sep 19, 10:15 - 14:15 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 10, 2025 - 10:14 UTC

Scheduled

We will be undergoing scheduled maintenance during this time.
Posted Sep 10, 2025 - 08:18 UTC
This scheduled maintenance affects: Epicor FP&A - Second - North America Region (epicor2.performancecanvas.com) (Web Portal, Epicor 2 Connect, Legacy Excel Add-On Reporting Service) and Epicor FP&A - Demo (demo.efp.cloud) (Web Portal - Demo).