Epicor@ FP&A - Users experienced temporary access issues

Incident Report for Epicor FP&A

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 09:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2025 - 05:22 UTC

Investigating

We are currently investigating this issue.
Posted Sep 11, 2025 - 05:08 UTC
This incident affected: Epicor FP&A - North America Region (epicor.performancecanvas.com) (Web Portal).